Elevated error rates for USA orders
Incident Report for Sendle
Resolved
This incident has been resolved.
Posted May 31, 2024 - 12:03 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 31, 2024 - 11:48 AEST
Investigating
We're experiencing elevated error rates for USA orders. This is related to an issue one of our upstream providers is experiencing.

Our engineers are investigating solutions to mitigate the impact on our side, and monitoring the upstream issue.
Posted May 31, 2024 - 10:39 AEST
This incident affected: United States - Quoting & Ordering.