Sendle Canada to USA cross-border ordering errors

Incident Report for Sendle

Resolved

This incident has been resolved.
Posted May 16, 2025 - 05:03 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 16, 2025 - 03:50 AEST

Investigating

We are investigating elevated error rates impacting Canada to USA cross-border orders.
Posted May 16, 2025 - 02:54 AEST
This incident affected: Canada - Quoting & Ordering.