Sendle global outage

Incident Report for Sendle

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 10:44 AEDT

Monitoring

AWS has implemented a fix, and Sendle systems are now back online. Intermittent errors or issues may still occur as the systems stabilize. We will provide an update once we confirm that all issues are fully resolved.
Posted Oct 21, 2025 - 06:28 AEDT

Investigating

We are currently experiencing a full outage of the Sendle platform as a result of widespread network and connectivity problems occurring in the AWS us-east-1 region. We are currently investigating ways to restore service as soon as possible.
Posted Oct 21, 2025 - 02:07 AEDT
This incident affected: Australia - Quoting & Ordering, Canada - Quoting & Ordering, United States - Quoting & Ordering, Tracking Pages, Website, Dashboard Integrations, Billing & Payments, API, and Sandbox.